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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

ch­¬ng4 : giíi thiÖu c¸c lÖnh vÏ (part) 

1.giíi thiÖu lÖnh Sweep , Revolve tool, lÖnh 
Sodilify....  

 Chó ý : b¶n chÊt cña lÖnh Sweep nµy lµ mÆt c¾t cña khèi h×nh 
tr­ît däc theo ®­êng dÉn quü d¹o , t¹i mäi ®iÓm trªn ®­êng quü ®¹o mÆt 
c¾t tr­ît theo ®­êng ®ã sÏ vu«ng gãc víi vÐct¬ ph¸p tuyÕn t¹i ®iÓm ®ã 

 Lóc nµy ta thÊy r»ng ph¶i x¸c ®Þnh ®­îc ®­êng quü ®¹o trong 
kh«ng gian , tiÕp theo lµ ph¶i vÏ ®­îc h×nh cña mÆt c¾t t¹i ®iÓm ®Çu mót 
cña ®­êng quü ®¹o ®ã. 

 Cã hai ph­¬ng ph¸p ®Ó cã ®­îc ®­êng quü ®¹o. 

 - lùa chän trùc tiÕp trªn khèi h×nh tån t¹i trong m«i truêng kh«ng 
gian . 

 - VÏ míi ®­êng quü ®¹o . 

 Sau khi khëi ®éng Proe2.0 kÝch File →  New  (hoÆc chän 

biÓu t­îng  trªn thanh c«ng cô) xuÊt hiÖn hép tho¹i,  ta ®Æt tªn 
b¶n vÏ lµ Vidu2 sau ®ã kÝch Ok ®Ó ®ãng  hép tho¹i l¹i. 

 -ThiÕt lËp ®­êng dÉn lµm viÖc kÝch File → Setworking  
directory →  tao th­  môc míi Baitap2 trong æ ®Üa C:→Ok 

 -ThiÕt lËp hÖ ®¬n vÞ ®o lµ mm 
kÝch thùc ®¬n Edit  →Setup  →  Units  chon Milimetter Newton 
Second  → Set   →  Ok   → Close  → Done 
  -Ta tiÕn hµnh vÏ h×nh hép 200x150x150 , chän bÒ mÆt ph¸c 
th¶o Front lµm bÒ mÆt tham chiÕu nh×n vu«ng gãc lµ Right. 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 

 Lóc nµy trªn mµn h×nh lµm viÖc cña Proe ta cã ®­îc khèi 
h×nh hép  

 B¾t ®Çu tiÕn hµnh vÏ lÖnh Sweep  

 KÝch Insert→Sweep    -Protrucsion             : vÏ vËt thÓ ®Æc 

            -thin Protrucsion    : vÏ vËt thÓ cã    

               chiÒu dµy 
                                                            

     -Cut :   dïng ®Ó c¾t khèi h×nh ®· cã. 
     -Surface  : dïng ®Ó vÏ mÆt 
→trong vÝ dô nµy ta chän d¹ng  Surface . XuÊt hiÖn hép tho¹i. 
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 Lóc nµy ta chän Sketch Traj ( vÏ ®­êng quü ®¹o) d­íi ®¸y 
mµn h×nh Proe xuÊt hiÖn dßng nh¾c " Select or create a 
SKETCHING PLANE." ta tiÕn hµnh chän mÆt ph¼ng Top lµm mÆt 
ph¼ng ph¸c th¶o → chon Defaut (chän mÆc ®Þnh) , Proe vµo m«i 
tr­êng vÏ ph¸c th¶o mµn h×nh ph¸c th¶o cã mÇu ®en. 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 Giíi thiÖu c¸c lÖnh trong m«i tr­êng vÏ ph¸c th¶o : 
 
 

 
 

 Ta kÝch lÖnh vÏ cung(   ) R=360mm , chØnh söa l¹i kÝch 

th­íc sao cho nh­ h×nh minh ho¹ → Done  ®Ó tho¸t khái m«i 
tr­êng ph¸c th¶o. 
 L­u ý : mòi tªn cã nghÜa ®ã lµ ®iÓm ®Çu cña ®­êng quü ®¹o , ta cã 
thÓ chän ®iÓm ®Çu kh¸c b»ng c¸ch nhÊp vµo ®iÓm ®Çu kia sao cho nã 
chuyÓn sang mÇu ®á sau ®ã 

 

KÝch Sketch →Feature tool →Start point 
 Sau khi tho¸t khái m«i tr­êng ph¸c th¶o thÊy xuÊt hiÖn thªm 
b¶ng Manu manager trong ®ã cã thªm hai thuéc tÝnh : Attributes 

 

Chän ®èi t­îng 
LÖnh vÏ ®­êng th¼ng 
LÖnh vÏ h×nh ch÷ nhËt 
LÖnh vÏ ®­êng trßn 
LÖnh vÏ cung trßn 
LÖnh bo cung  
LÖnh vÏ Spline 
LÖnh vÏ ®iÓm 
LÖnh copy c¹nh 
Ghi kÝch th­íc  
Söa gi¸ trÞ kÝch th­íc 
Rµng buéc c¸c ®èi t­îng. 

§¸nh ch÷ 

Xo¸ ®èi t­îng 

§èi xøng 

Hoµn tÊt  

Kh«ng lµm g× 
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 Open Ends : khi hoµn thµnh ta ®­îc bÒ mÆt hë  
  
 Capped Ends : ®­îc bÒ mÆt hai ®Çu sÏ ®­îc bÞt   
kÝn . 
 Ta chän Open End →Done. 
Proe d­íi ®¸y mµn h×nh xuÊt hiÖn dßng nh¾c sau: 
" Now sketch the cross-section" : b©y giê tiÕn hµnh 

vÏ mÆt c¾t . 

ta vÏ cung trßn  nh­ h×nh minh ho¹ → Done tho¸t khái m«i 
tr­êng ph¸c th¶o. 

 

 Xoay ®éng ®Ó xem →Ok  ®Ó hoµn thµnh. 
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 B©y giê ta dïng mÆt Sweep võa vÏ ®Ó c¾t khèi h×nh hép 
(Extrude tool ) ®· vÏ ë trªn. 

 Chän  mÆt Surface id 66 võa vÏ trªn 

c©y th­ môc →Edit→Solidify....   
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 Chän biÓu t­îng Cut  →Flip →Done 

 

 Ghi chó : vÒ Solidify.. lÖnh nµy dïng bÒ mÆt ®· vÏ c¾t khèi 
solid ®· tån t¹i tr­íc nã , chuyÓn tõ d¹ng Surface kÝn sang d¹ng 
Solid vËt thÓ ®Æc , dïng bÒ mÆt bÞt kÝn c¸c lç hë cña Solid 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

2.lÖnh Revolve ( vÏ khèi h×nh trßn xoay)( ). 

 VÒ b¶n chÊt cña lÖnh nµy ®ã lµ mÆt c¾t quay quanh 1 trôc  
 → - Ph¶i vÏ ®­îc mÆt c¾t. 
      -Ph¶i x¸c ®Þnh ®­îc trôc quay. 

 KÝch biÓu t­îng  trªn Tool bar , chän d¹ng Solid 
→Placement →Define xuÊt hiÖn hép tho¹i Sketch  

 

 Chän mÆt ph¼ng ph¸c th¶o nh­ h×nh minh ho¹ → Sketch 
vµo m«i tr­êng vÏ ph¸c th¶o. 

 VÏ lÖnh Rectangle ( ) vµ chØnh l¹i kÝch th­íc , vÏ ®­êng 
Center line lµm trôc quay   →Done tho¸t khái m«i tr­êng vÏ 
ph¸c th¶o. 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 

 Xoay ®éng m« h×nh ®Ó nh×n → chän biÓu t­îng Cut  
→Done ®Ó hoµn tÊt c«ng viÖc. 

 

 KÕt thóc bµi thùc hµnh tiÕn hµnh sao l­u b¶n vÏ kÝch File 
→Save.  
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 Ta cã thÓ lµm vÝ dô minh ho¹ thùc hµnh 4 lÖnh vÏ c¬ b¶n 
Revolve , Sweep , Shell , Round ®Ó vÏ cèc n­íc cã quai . 

 Dïng lÖnh Revolve h×nh biªn d¹ng cèc , mÆt ph¼ng ph¸c 
th¶o lµ mÆt Top  

 

 Sau ®ã bo trßn c¹nh ®¸y r=6 mm , dïng lÖnh Shell t¹o rçng 
khèi h×nh cã chiÒu dÇy thµnh cèc 3mm , dïng lÖnh bo trßn Round 
miÖng cèc r=1.5mm . 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 T¹o quai cèc b»ng lÖnh Sweep , chän mÆt ph¼ng Top lµm 
mÆt ph¸c th¶o vÏ ®­êng quü ®¹o .Kªt thóc ®­îc h×nh nh­ minh 
ho¹ 

 

2:LÖnh Extrude tool 

 §©y lµ lÖnh c¬ b¶n trong Proe lÖnh nµy dïng ®Ó ®ïn khèi .VÒ c¸ch 
lµm lÖnh nµy ta chó ý : -Ph¶i vÏ ®­îc mÆt ph¸c th¶o . 

                             - NhËp chiÒu cao .  

 KÝch biÓu t­îng ( ) trªn Toolbar hoÆc kÝch trªn menu th¶ 
xuèng Insert → Extrude tool . 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 Thuéc tÝnh cña vËt thÓ cã d¹ng ®Æc Solid  

   Thuéc tÝnh cña vËt thÓ cã d¹ng bÒ mÆt Surface. 

     nhËp kÝch th­íc chiÒu cao theo mét h­íng ,   sau 

khi nhËp kÝch th­íc chiªï cao h×nh gi·n theo hai h­íng,  chiÒu 
cao cña khèi h×nh ®­îc x¸c ®Þnh b»ng c¸ch ®ïn tíi mét mÆt ph¼ng 
hay Surface , point , c¹nh ..... 

 : NhËp kÝch th­íc chiÒu cao. 

    : §¶o chiÒu khèi h×nh 

   : Khèi h×nh vÏ cã chiÒu dµy thµnh . 

   : Dïng ®Ó c¾t khèi h×nh ®· cã tr­íc nã 

 : nh×n tr­íc khèi h×nh vÏ . 

 : Hoµn thµnh viÖc thiÕt lËp vÏ . 

 : Tho¸t khái lÖnh mµ kh«ng lµm g× . 
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Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 KÝch Placement →Define →chän mÆt ph¼ng Right lµm mÆt 
ph¼ng ph¸c th¶o vµ mÆt Top lµm bÒ mÆt tham chiÕu nh×n vu«ng 

gãc .           → Sketch  

 Ta vµo m«i tr­êng vÏ ph¸c th¶o cña Proe kÝch biÓu t­îng vÏ 

h×nh ch÷ nhËt(  ) 200x200 chØnh l¹i cho c©n t©m → Done tho¸t 

khái m«i tr­êng ph¸c th¶o → nhËp vµo « chiÒu cao 150mm →  
done ®Ó hoµn thµnh . 

 

3. lÖnh CHamfer . 

 3.1.v¸t mÐp c¹nh (Edge chamfer) 

 LÖnh nµy dïng ®Ó v¸t c¹nh khèi h×nh .Ta còng cã thÓ lµm theo hai 
c¸ch ®Ó vµo lÖnh nµy  
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 KÝch  trªn Manu bar (hoÆc Insert → Chamfer →Edge 
chamfer ). 

 TiÕn hµnh chän mét c¹nh cña h×nh hép  

 : v¸t c¹nh b»ng nhau. 

 : v¸t c¹nh chiÒu dµi kh«ng b»ng nhau khi ®ã ta nhËp 
kho¶ng c¸ch D1 vµ D2 gi¸ trÞ kh¸c nhau. 

  v¸t c¹nh ta ph¶i nhËp gãc vµ kho¶ng c¸ch. 

 :gãc mÆc ®Þnh lµ 45 ®é ta chØ nhËp vµo kho¶ng c¸ch. 

 

→ Done ®Ó hoµn thµnh . 

3.2 V¸t mÐp ®Ønh  

 Insert → Chamfer → Corner chamfer thÊy xuÊt hiÖn dßng 
nh¾c " Select corner to chamfer : lùa chän gãc ®Ó tíi v¸t c¹nh"→ lùa 
chän b»ng c¸ch kÝch chuét tr¸i lªn mét c¹nh nh­ h×nh minh ho¹ 
d­íi ®©y. 
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→ chän Enter - input d­íi ®¸y xu©t hiÖn hép tho¹i 

" Enter length dimension along highlighted edge : 60"→ Accep 
value lóc nµy Proe chuyÓn sang c¹nh kÕ tiÕp (c¹nh nµy chuyÓn 
sang mµu xanh l¸ c©y) → chän Enter - input d­íi ®¸y xu©t hiÖn 
hép tho¹i 

" Enter length dimension along highlighted edge : 40"→ Accep 
value  

 C¹nh t­¬ng tù ta còng lµm c¸c b­íc tuÇn tù nh­ trªn nhËp 
vµo gi¸ trÞ v¸t mÐp 50mm .→ Ok ®ãng hép tho¹i Corner chamfer 
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4.LÖnh Round tool 

 LÖnh nµy dïng ®Ó bo trßn c¹nh .Ta còng cã thÓvµolÖnh heo mét 
trong hai c¸ch sau. 

 KÝch  trªn Manu bar (hoÆc Insert → Round  ) →chän 
mét c¹nh→nhËp b¸n kÝnh 30mm 

 

→ Done   ®Ó hoµn thµnh . 
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5.LÖnh t¹o lç Hole tool . 

 Cã hai kiÓu    - Lç tr¬n.  

        - Lç cã ren.   

 

  : kiÓu ren  

   : §­êng kÝnh vµ bø¬c ren. 

 : ChiÒu s©u . 

     : v¸t mÐp khi t¹o ren. 

   : T¹o vai . 

 Trang Placement : dïng ®Ó ®Þnh vÞ nhËp kÝch th­íc tham 

chiÕu vµ bÒ mÆt trªn ®Æt lç . lªn bÒ mÆt ®ã. 

 

 KÝch  trªn toolbar → chän bÒ mÆt ®Ønh trªn  
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→ kÝch trang Placement→ nhÊp trang Secondary Referent cho 
nã hiÖn s¸ng (nã ®ang yªu cÇu chän hai tham chiÕu ®Ó ®Þnh vÞ 
®­îc hÖ lç)→ nhÊn gi÷ CTRl vµ chän ®ång thêi hai mÆt ph¼ng 
Front vµ Top sau ®ã chØnh söa l¹i kÝch th­íc nh­ h×nh minh ho¹ 
d­íi ®©y. 

 

 NhËp ®­êng kÝnh lç 40 mm s©u 80mm → Done ®Ó hoµn 
thµnh ta ®­îc lç trªn vËt thÓ lóc nµy trªn c©y th­ môc còng cã xuÊt 
hiÖn thªm lç Hole . 

6. lÖnh Mirror  

 LÖnh nµy cã t¸c dông lµm ®èi xøng ®èi t­îng nµo ®ã qua mét mÆt 
ph¼ng . 
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 Chän lç Hole1 trªn c©y th­ môc → kÝch biÓu t­îng  trªn 
manu bar (hoÆc kÝch Edit → mirror ) → d­íi ®¸y mµn h×nh xuÊt 
hiÖn dßng nh¾c " Select a plane to mirror about : lùa chän mÆt ph¼ng 
®Ó ®èi xøng ®èi t­îng  qua mÆt nµy" →®­a trá chuét tr¸i nhÊp chän 
mÆt ph¼ng Top → Done ®Ó kÕt thóc qu¸ tr×nh Mirror. 

 

7.lÖnh Helical sweep  

 LÖnh nµy dïng ®Ó vÏ Ren , lß xo cã b­íc thay ®æi hoÆc kh«ng ®æi 
hay c¸c bÒ mÆt Surface xo¾n.. 

 C¸ch nhËp lÖnh Insert → 
Helical sweep  

 

 

 
Protrusion : d¹ng vËt thÓ ®Æc  
Thin Protrusion  : d¹ng vËt thÓ cã chiÒu dµy thµnh. 
Cut : dïng ®Ó c¾t ®èi t­îng ®· cã tr­íc nã 
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Thin cut : t¹o ®èi t­îng c¾t cã chiÒu dµy. 
Surface : t¹o m« h×nh d¹ng bÒ mÆt. 
 §Ó thùc hµnh lÖnh nµy ta tiÕn hµnh vÏ bu l«ng. 
 Sau khi khëi ®éng Proe2.0 kÝch File →  New  (hoÆc chän 

biÓu t­îng  trªn thanh c«ng cô) xuÊt hiÖn hép tho¹i,  ta ®Æt tªn 
b¶n vÏ lµ Bulong sau ®ã kÝch Ok ®Ó ®ãng  hép tho¹i l¹i. 

 ThiÕt lËp hÖ ®¬n vÞ ®o lµ mm. 

  VÏ ®Çu bulong tr­íc .KÝch Insert →Extrude 

tool→placement→ define   chän 
mÆt ph¼ng ph¸c thao vµ tham chiÕu nh­ h×nh minh ho¹ trªn→ 
Sketch → ®ãng hép tho¹i Reference l¹i  

  Trong m«i tr­êng ph¸c th¶o ta dïng lÖnh Line   vÏ t­¬ng 
®èi ®a gi¸c 6 c¹nh kh«ng chó ý l¾m ®Õn kÝch th­íc. 
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 Sau ®ã kÝch biÓu t­îng Contraints  xuÊt hiÖn b¶ng rµng 

buéc  ta kÝch chän  ®ã lµ rµng buéc c¸c ®èi 
t­îng Line cã chiÒu dµi b»ng nhau , ta kÝch chän liªn tiÕp hai ®èi 
t­îng liÒn kÒ nhau xuÊt hiÖn c¸c kÝch th­íc rµng buéc b»ng nhau 
= L1 lóc nµy ta tiÕn hµnh chän vµ chØnh söa kÝch th­íc sao cho 
khèi h×nh c©n t©m nhËp thªm kÝch th­íc gãc vµ söa gãc ®ã = 120 

®é         → Done  
®Ó tho¸t khái m«i tr­êng ph¸c th¶o.→ nhËp chiÒu cao 18 mm → 
Done  

 T­îng nh­ vËy ta dïng lÖnh Extrude vÏ ®­êng trßn ®­êng 
kÝnh 20 mm cao 80mm  
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→ Done. 

 TiÕn hµnh v¸t mÐp c¹nh trªn chän Insert → chamfer → 
Edge chamfer → dïng chuét tr¸i nhÊp chän c¹nh cÇn v¸t mÐp, 

 

→ Done  
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 Ta bo trßn c¹nh d­íi ®¸y Insert → Round → dïng chuét tr¸i 
chän c¹nh d­íi . 

 → Done  

 B¾t ®Çu vÏ Ren cho bu l«ng 

 KÝch Insert → Helical  sweep → Cut → XuÊt hiÖn thªm 

menu manager     → Done  
 Constant : cã b­íc kh«ng thay ®æi 
 Variable  : cã b­íc thay ®æi. 
 Thu Axis : tiÕt diÖn vßng quanh trôc 
 Norn To Traj: TiÕt diÖn vu«ng gãc ®­êng h­íng ren. 
 Right Handed : ren ph¶i 
 Left    Handed : ren tr¸i 
D­íi ®¸y mµn h×nh xuÊt hiÖn dßng nh¾c " Select or create a 
SKETCHING PLANE" → dïng chuét tr¸i chän mÆt ph¼ng Top lµm 
mÆt ph¼ng ph¸c ph¶o → Okay → Defaut → Proe chuyÓn sang 
mµn h×nh vÏ ph¸c th¶o trong trang Reference ta chän thªm hai 
tham chiÕu n÷a . 
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→ dïng lÖnh Line  vÏ ®­êng h­íng c¾t ren vµ chØnh l¹i chiÒu 
dµi ®­êng ren nh­ h×nh minh ho¹. 

 

→ Ta vÏ ®­îng Centerline  → Done 
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XuÊt hiÖn dßng nh¾c  → Accep value .Proe l¹i vµo 
trong m«i tr­êng ph¸c th¶o lóc nµy ta tiÕn hµnh vÏ biªn d¹ng 
Profile r¨ng .Trong vÝ dô nµy t«i dung lÖnh Line vÏ t­¬ng ®èi mét 

con dao tiÖn.  chó 
ý trong qu¸ tr×nh vÏ ph¸c th¶o ®Çu r¨ng < 1.5mm → Okay → OK 
®ãng hép tho¹i vÏ ren ta ®­îc h×nh bu l«ng nh­ d­íi ®©y. 

 

 Dïng lÖnh Revolve chän mÆt ph¼ng ph¸c th¶o lµ mÆt Top 
vµ vÏ chØnh söa kÝch th­íc nh­ h×nh minh ho¹ d­íi , vÏ ®­êng 
Centerline → Done tho¸t khái m«i tr­êng ph¸c th¶o → Chän 
thuéc tÝnh Cut → Done hoµn thµnh. 
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KÕt thóc bµi thùc hµnh  . 
 File → Save 

8.lªnh vÏ g©n RIb 

 LÖnh nµy dïng ®Ó vÏ g©n t¨ng cøng cho s¶n phÈm .B¶n chÊt 
cña lÖnh nµy kh«ng kh¸c so víi lÖnh Extrude tool lµ mÊy nã ®­îc 
kÐo dµi theo hai h­íng , mÆt c¾t ph¸c th¶o kh«ng ph¶i lµ ®­êng 
cong kÝn nã ph¶i hë vµ ph¶i tiÕp gi¸p v¬Ý hai bÒ mÆt cña vËt thÓ 
tr­íc khi vÏ g©n. 
 §Ó hiÓu râ vÒ lÖnh nµy ta lµm vÝ dô minh ho¹ d­íi ®©y. 
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 File→ New → *.part → Gan 
 ThiÕt lËp hÖ ®¬n vÞ ®o lµ  mm. 
 
 VÏ lÖnh Extrude tool vÏ khèi h×nh hép cã kÝch th­íc nh­ sau  
200x200x40 mm , sau ®ã vÉn dïng lÖnh Extrude vÏ ®­êng trßn 
®­êng kÝnh 110mm t¹i t©m tham chiÕu , cã chiÒu cao 100mm 
®­îc h×nh nh­ minh ho¹ d­íi ®©y. 

 

 KÝch biÓu t­îng  (hoÆc Insert → Rib..) → Referent → 
Define → chän b»ng chuét tr¸i nhÊp vµo bÒ mÆt Top lµm bÒ mÆt 
ph¸c th¶o vµ mÆt Right lµm mÆt nh×n tham chiÕu vu«ng gãc → 
Sketch lóc nay Proe vao trong m«i tr­êng vÏ ph¸c th¶o , trong m«i 

tr­êng ph¸c th¶o xuÊt hiÖn trang 
Reference vµ ®· tù ®éng chän hai 
mÆt ph¼ng Right va Front lµm tham 
chiÕu kÝch th­íc . 

ta chän thªm hai c¹nh nh­ h×nh minh 
ho¹ ®Ó truy b¾t ®iÓm c¹nh phôc vô vÏ 
®­êng th¼ng sau nµy. 
→ ®ãng trang Reference nµy l¹i  
kÝch biÓu t­îng vÏ ®­êng th¼ng  

Line   
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 ChØnh söa l¹i kÝch th­íc nh­ minh ho¹ d­íi ®©y. → Done  
tho¸t khái m«i tr­êng ph¸c th¶o .→ nhËp chiÒu dÇy g©n 10mm vµo 
«  

 nÕu kh«ng thÊy g©n xuÊt hiÖn trªn mµn h×nh 

mµu vµng th× c¸c b¹n cã thÓ kÝch biÓu t­îng Flip  ®Ó ®¶o chiÒu 
sao cho mòi tªn h­êng vµo trong vËt thÓ → Accep value (hoÆc cã 
thÓ nhÊn phÝm chuét gi÷a ®Ó hoµn thµnh vµ tho¸t lÖnh) 
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c¸c h×nh minh ho¹ 
 

9.LÖnh Pattern  

 VÒ c¬ b¶n lÖnh nµy gièng nh­ lÖnh Array trong Autocard  
(VÝ dô :chän vËt thÓ cÇn Pattern , tiÕp theo chän trôc quay , sè vËt 
thÓ , gãc quay.) 
 §Ó hiÓu thªm vÒ lÖnh nµy ta lµm vÝ dô minh ho¹ d­íi ®©y. 
 LÊy bµi tËp trªn lµm minh ho¹ .Trªn c©y th­ môc Model Tree 

chän   g©n Rib1→ Edit → Pattern  ta chän 
kiÓu Pattern (sets the type of Pattern ) lµ Axis d­íi ®¸y mµn h×nh 
xuÊt hiÖn dßng nh¾c (" Select a Datum Axis to define the pattern 
center" tam dÞch lùa chän trôc quay cho lÖnh Pattern) → Dïng 
chuét tr¸i nhÊp chän nhÊp chän trôc A2 

 

 NhËp sè ®èi t­îng lµ 4 vµ gãc quay lµ 360®é/4(hoÆc nh©p 
th¼ng 90 )→ Done  
C¸c b¹n ph¶i ®­îc nh­ h×nh minh ho¹ d­íi ®©y. 
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10.lÖnh Blend 

 VÒ b¶n chÊt cña lÖnh Blend : 
  Parallel : Gåm nh÷ng mÆt c¾t song song nhau , ta ph¶i 
nhËp kho¶ng c¸ch gi÷a c¸c mÆt c¾t nµy 
 Rotational : Gåm nh÷ng mÆt c¾t quay xung quanh trôc , ta 
ph¶i nhËp gãc gi÷a c¸c mÆt c¾t . 
 General : KÕt hîp c¶ hai kiÓu trªn  

10.1 kiÓu Parallel : chóng ta lµm vÝ dô minh ho¹ d­íi ®©y. 

  File→ New ®Æt tªn b¶n vÏ lµ Blend. 
  thiÕt lËp hÖ ®¬n vÞ ®o lµ mm. 

kÝch Insert → Blend xuÊt hiÖn hép tho¹i  
chän kiÓu Parllel , Regular Sec , Sketch Sec → 
Done  ta l¹i thÊy xuÊt hiÖn hép 
tho¹i Menu Manager  
Gi¶i thÝch c¸c thuéc tÝnh 

Straight : nèi c¸c mÆt c¾t  
   th¼ng 

Smooth : nèi c¸c mÆt c¾t 
theo d¹ng  cong tr¬n.Trong vÝ dô 
nµy ta chän kiÓu Straight lµm vÝ dô 
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→ Done chän mÆt ph¼ng ph¸c th¶o lµ mÆt Top → Okay → defaut  
lóc nµy Proe vµo trong m«i tr­êng ph¸c th¶o vÏ c¸c mÆt c¾t ta 
®ãng trang Refrence l¹i vµ tiÕn hµnh vÏ mÆt c¾t thø nhÊt lµ mét 
h×nh ch÷ nhËt 100x100mm sau ®ã chØnh söa kÝch th­íc sao cho 
h×nh ch÷ nhËt c©n t©m. 

 

 Ta thÊy xuÊt hiÖn mòi tªn , ®ã lµ ®iÓm ®Çu tiªn cña mÆt c¾t 
nµy , ta còng cã thÓ thay ®æi ®iÓm ®Çu tiªn b»ng c¸ch nhÊp vµo 
®iÓm kh¸c sao cho nã chuyÓn sang mÇu ®á  
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 Sau ®ã kÝch Sketch → Feature tools→ Start point  

 Hoµn thµnh song mÆt c¾t ®Çu tiªn ta ph¶i kho¸ nã l¹i vµ 

chuyÕn sang mÆt c¾t thø hai b»ng c¸ch nh­ sau .KÝch Sketch → 

Feature tools→ toggle section thÊy trªn mµn h×nh mÆt c¾t thø 

nhÊt lóc nµy chuyÓn sang d¹ng mÇu n©u x¸m . 

 B©y giê ta tiÕn hµnh vÏ mÆt c¾t thø hai ta còng kÝch biÓu 

t­îng vÏ h×nh ch÷ nhËt Rectang   sau ®ã vÏ h×nh ch÷ nhËt 
50x50 vµ chØnh söa kÝch th­íc sao cho c©n t©m  
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 C¸c b¹n nhí chØnh ®iÓm ®Çu tiªn sao cho nã nh­ h×nh minh 
ho¹ , nÕu kh«ng khèi h×nh cña c¸c b¹n cã thÓ bÞ xo¾n. 
 Sau khi vÏ song ta còng kho¸ mÆt c¾t thø hai nµy l¹i  
Sketch → Feature tools→ toggle section  
 TiÕn hµnh vÏ mÆt c¾t thø ba còng lµ mét h×nh ch÷ nhËt 
120x120 
 Sau ®ã kÝch Done ®Ó tho¸t khái m«i tr­êng ph¸c th¶o  

 Lóc nµy xuÊt hiÖn dßng nh¾c  ®©y chÝnh 
lµ kho¶ng c¸ch gi÷a mÆt c¾t 1  vµ 2 ta nhËp vµo kÝch th­íc 100m 
→ Accep value  , ta l¹i nhËp kho¶ng c¸ch 150 vµo , ®©y lµ 
kho¶ng c¸ch mÆt c¾t thø 2 ®Õn mÆt c¾t 3→ Accep value  ta cã 
thÓ xem tr­íc khi hoµn thµnh khèi h×nh nÕu kh«ng thÊy ®óng theo 
yªu cÇu cã thÓ tiÕn hµnh söa ch÷a ®Þnh nghÜa l¹i → Preview ®­îc 
khèi h×nh nh­ d­íi ®©y 
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 Ta cã thÓ söa l¹i thuéc tÝnh khèi h×nh b»ng c¸ch kÝch chän 
Attributes  
kÝch Define → chän Smooth → Done 
→ Preview ta ph¶i ®­îc nh­ h×nh vÏ 
minh ho¹ d­íi ®©y. 
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 Hoµn thµnh → Ok  
 C¸c b¹n cã thÓ lµm thªm nh÷ng vÝ dô d¹ng Cut, Surface ..  
vv . §Ó hiÓu s©u h¬n vÒ lÖnh Blend parallel. 

10.2 KiÓu Rotational 

 KÝch chän khèi h×nh trªn c©y th­ môc vµ xo¸ ®i ®Ó lµm vÝ dô 
minh ho¹ d­íi ®©y. 

kÝch Insert → Blend xuÊt hiÖn hép tho¹i 
  
ta chän Rotational → Done xuÊt 
hiÖn b¶ng thuéc tÝnh trong vÝ dô 
nµy ta chän d¹ng smooth  

→ Done  

 

 
 D­íi ®¸y mµn h×nh xuÊt hiÖn dßng giao diÖn ng­êi dïng  
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" Select or create a SKETCHING PLANE:®©y cã nghÜa lµ lùa chän 
mÆt ph¼ng ph¸c th¶o " ta còng chän m¨t ph¼ng Top lµ mÆt ph¸c 
th¶o.→ Okay → Defaut .TiÕn hµnh ®ãng trang Reference l¹i vµ 
vÏ mét h×nh ch÷ nhËt  100x100 vµ chØnh sao cho kÝch th­íc c©n 
t©m .Sau ®ã vÏ t¹o ®é XOY b»ng c¸ch kÝch Sketch → Coordinate 
System ®­îc nh­ h×nh minh ho¹ d­íi ®©y. 

 

 Sau ®ã kÝch Done ®Ó hoµn thµnh mÆt c¾t thø nhÊt  
 Lóc nµy d­íi ®¸y mµn h×nh xuÊt hiÖn dßng nh¾c  

 tam dÞch nh­ sau : nhËp vµo 
gãc quay quanh trôc Y to¹ ®é XOY  mµ ta ®· vÏ trong mÆt c¾t thø 
ph¸c th¶o thø nhÊt .Ta nhËp vµo gãc quay 90 ®é .→ Accep value   
 Proe l¹i vµo trong m«i tr­êng vÏ ph¸c th¶o ta tiÕn hµnh vÏ 
mÆt c¾t thø hai .KÝch biÓu t­îng vÏ h×nh ch÷ nhËt Rectangle kÝch 
th­íc 50x50mm sau ®ã vÏ ®­êng Centerline t¹i ®iÓm gi÷a cña 
c¹nh ®øng . Sau ®ã vÏ t¹o ®é XOY b»ng c¸ch kÝch Sketch → 
Coordinate System ®­îc nh­ h×nh minh ho¹ d­íi ®©y 

 

→ Done ®Ó tho¸t khái m«i tr­êng vÏ ph¸c th¶o  
 D­íi ®¸y mµn h×nh xuÊt hiÖn dßng nh¾c  

t
µ

i 
li

Ö
u

 h
ä

c
 t

h
iÕ

t
 k

Õ
 v

µ
 t

h
ù

c
 h

µ
n

h
 t

r
o

n
g

 P
r

o
 e

n
g

in
e

e
r

 2
.0

 

mailto:Dangthanhhai1978@yahoo.com


Dangthanhhai1978@yahoo.com                           
 

Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

  : Cã nghÜa lµ cã tiÕp tôc vÏ mÆt c¾t n÷a 
hay kh«ng .Trong vÝ dô nµy ta chØ lµm 2 mÆt c¾t vËy trong tr­êng 
hîp nµy chän No .KÝch biÓu t­îng Preview nh×n trøoc ta ®­îc khèi 
h×nh nh­ minh ho¹ d­íi ®©y. 

 

→ Ok ®Ó hoµn thiÖn khèi h×nh. 
 B¶n chÊt cña lÖnh nµy ®ã lµ mÆt c¾t thø nhÊt qua quanh trôc Y tíi 
mÆt c¾t thø 2  
 C¸c b¹n cã thÓ tiÕn hµnh vÝ dô 3 hay 4 mÆt c¾t ®Ó hiÓu thªm vÒ b¶n 
chÊt cña lÖnh nµy. 

10.3 kiÓu General  

 KÕt hîp hai kiÓu trªn l¹i c¸c b¹n tù lµm vÝ dô minh ho¹ ®Ó 
hiÓu thªm . 

11. lÖnh Swept Blend 

 §©y lµ lÖnh kÕt hîp = lÖnh Sweep + lÖnh blend 
 Ta ph¶i vÏ ®­îc ®­êng quü ®¹o cña khèi h×nh chuÈn bÞ vÏ hay cã 
thÓ chän ®­êng dÉn quü ®¹o tõ m« h×nh ®· cã tr­íc nã   
 T­¬ng t­ ta còng cã hai c¸ch  
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 -VÏ mÆt c¾t t¹i c¸c mót cña ®­êng quü ®¹o 
 -Chän mÆt c¾t , mÆt c¾t nµy ®· cã vµ ®i qua c¸c ®iÓm mót cña 
®­êng quü ®¹o. 
 Më b¶n vÏ míi FIle → New  
 ThiÕt lËp hÖ ®¬n vÞ ®o lµ hÖ mm. 
 kÝch  Insert → Swept blend  → Protrucsion .. 
 

 
 XuÊt hiÖn Menu Manager  
B¶ng tuú chän c¸c th«ng sè , ta gi¶i thÝch c¸c tuú chän 
nµy 
Select Sec : lùa chän mÆt c¾t 
Sketch SEc : vÏ c¸c mÆt c¾t t¹i c¸c ®iÓm mót. 
Nrmto OriginTraj : MÆt c¾t vu«ng gãc víi ®­êng quü 
®¹o. 
Pivot Dir : mÆt c¾t h­íng theo mét h­íng chØ ®Þnh 
Norm to Traj : MÆt c¾t vu«ng gãc víi mét quü ®¹o 
kh¸c mµ ta chØ ®Þnh. 

PhÇn mÒm tù chän mÆc ®Þnh nh­ trªn lóc nµy ta dïng chuét tr¸i 
nhÊn chän DOne → Sketch Traj ( vÏ ph¸c th¶o ®­êng quü ®¹o) → 
chän mÆt ph¶ng Top lµm mÆt ph¼ng ph¸c th¶o → Okay → Defaut 
, sau ®ã ®ãng trang Reference l¹i vµ tiÕn hµnh vÏ mét ®­êng 

th¼ng  chiÒu dµi 200 vµ c¸ch trôc X 50 mm , sau ®ã vÏ mét 

cung  tiÕp tuyÕn b¸n kÝnh 300 mm chØnh kÝch th­íc l¹i nh­ h×nh 
hinh ho¹ d­íi ®©y 

 

 Ta thÊy b¶n vÏ ph¸c th¶o nµy cã ba ®Çu mót tÊt c¶ , qua ba 
®Çu mót nµy ta tiÕn hµnh vÏ 3 mÆt c¾t . 
→ Done ®Ó tho¸t khái m«i tr­êng vÏ ph¸c th¶o ®­êng quü ®¹o  

→ Accept Value  .Vµo trong m«i tr­êng ph¸c th¶o ta tiÕn hµnh 
vÏ mét ®­êng trßn ®­êng kÝnh 40mm  → Done ®Ó hoµn thµnh 
mÆt c¾t thø nhÊt  
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→ Accept Value  ®Ó vµo m«i tr­êng ph¸c th¶o vÏ mÆt c¾t thø 
hai . T­¬ng tù ta tiÕn hµnh vÏ ®­êng trßn ®­êng kÝnh 60mm   
→ Done  
→ Accept Value  ®Ó vµo m«i tr­êng ph¸c th¶o vÏ mÆt c¾t thø 
hai . T­¬ng tù ta tiÕn hµnh vÏ ®­êng trßn ®­êng kÝnh 30mm   
→ Done  
 Ta cã thÓ nh×n tr­íc m« h×nh b»ng c¸ch nhÊn Preview  

 

 Sau ®ã kÝch OK ®Ó hoµn thµnh khèi h×nh võa t¹o. 
 Ghi chó : C¸c b¹n cã thÓ vÏ mÆt c¾t lµ c¸c h×nh kh¸c nh­ng chó ý 
c¸c ®èi t­îng ë tõng mÆt c¾t ph¶i b»ng nhau kh«ng cã khèi h×nh sÏ b¸o 
lçi kh«ng t¹o ®­îc. 

12.lªnh boundary blend 

 §©y lµ mét trong nh÷ng lÖnh quan träng nhÊt trong Proe , tõ lÖnh 
nµy ta cã thÓ tiÕn hµnh vÏ nh÷ng bÒ mÆt cong phøc t¹p , kÕt hîp c¸c bÒ 
mÆt nµy Cut hoÆc Merge c¸c bÒ mÆt l¹i vµ chuyÓn sang d¹ng Solid ®Ó 
môc ®Ých cuèi cïng ®­îc mét solid cã biªn d¹ng cong nh­ mong muèn 
.LÖnh nµy t¹o d¹ng bÒ mÆt Surface ®i qua c¸c ®­êng c¬ ®· vÏ tr­íc ®ã cã 
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thÓ theo mét h­íng hoÆc theo hai h­íng .§Ó minh ho¹ vµ dÔ dµng nhÊt 
kh«ng cã g× b»ng nh÷ng vÝ dô thùc tÕ tõ ®ã mäi ng­êi cã thÓ hiÓu râ b¶n 
chÊt cña lÖnh nµy. 

 Ta tiÕn hµnh vÏ khèi h×nh hép b»ng lÖnh Extrude tool kÝch 
th­íc 200x200x150mm .MÆt ph¼ng ph¸c th¶o lµ mÆt Top mÆt nh×n 
vu«ng gãc lµ mÆt Right.  

 

 Sau ®ã ta dùng 4 ®­êng c¬ ë bèn mÆt bªn cña khèi h×nh 
hép.§Çu tiªn ta dùng ®­êng c¬1 trªn mÆt bªn song song víi mÆt 
Front . 

 KÝch biÓu t­îng  trªn menu bar  
Chän mÆt ph¼ng ph¸c th¶o nh­ h×nh minh ho¹ d­íi ®©y 
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→ Sketch , vµo trong m«i tr­êng ph¸c th¶o , trang Reference 
®ang hiÖn s¸ng ta chän thªm hai canh ®øng lµm tham chiÕu ®Ó 

truy b¾t ®iÓm trªn hai c¹nh nµy .Sau ®ã tiÕn hµnh vÏ cung trßn  
vµ chØnh söa laÞ kÝch th­íc nh­ h×nh minh ho¹ d­íi ®©y. 

 

Sau ®ã kÝch Done ®Ó hoµn thµnh ®­êng c¬ 1. 
 B©y giê tiÕn hµnh vÏ ®­êng c¬ thø 2 
 T­¬ng t­ nh­ vËy ta chän mÆt kÕ bªn lµm mÆt ph¼ng ph¸c 
th¶o .Trong lóc nµy ®­êng c¬1 ®· tån t¹i vµ ®­êng c¬ 2 cña ta 
chuÈn bÞ vÏ kh«ng cïng n»m trªn mét mÆt ph¼ng ta muèn truy b¾t 
®iÓm cuèi cña ®­êng c¬ tr­íc sao cho hai ®­êng c¬ nµy cã giao 
nhau trong kh«ng gian = mét ®iÓm.Lóc nµy trang Reference vÉn 
hiÖn s¸ng sau khi vµo m«i tr­êng ph¸c th¶o ta chän mét c¹nh cña 
khèi h×nh hép vµ ®iÓm ®Çu mót cña ®­êng c¬1  
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 Sau khi xoay ®éng ta muèn trë l¹i mÆt c¾t nh×n vu«ng gãc 

kÝch biÓu t­îng  .T­¬ng tù nh­ vËy ta vÏ cung trßn nh­ h×nh 
minh ho¹ d­íi ®©y. 

 
 Cø tuÇn t­ nh­ vËy ta vÏ thªm ®­îc ®­êng c¬3 vµ ®­êng c¬4 
.Chó ý c¸ch truy b¾t ®iÓm cuèi nÕu 4 ®­êng c¬ nµy kh«ng c¾t nhau 
th× khi ®ã ta x©y dùng mÆt Boundary Blend nã kh«ng thÓ lµm ®­îc 
vµ b¸o lçi .Ta ®­îc vÏ ®­îc4 ®­êng c¬ nh­ h×nh minh ho¹ d­íi 
®©y. 

 

 12.1 vÝ dô t¹o mÆt Boundary theo mét h­íng 
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 KÝch biÓu t­îng  trªn menu bar .NhÊn CTRL chän ®ång 
thêi hai ®­êng c¬1 vµ c¬3 nh­ h×nh minh ho¹ d­íi ®©y. 

 
→ Accep Value ®Ó hoµn thµnh .§©y lµ vÝ dô t¹o mÆt cong theo 
mét h­íng .Sau ®ã ta chon bÒ mÆt nµy vµ dïng nã ®Ó c¾t khèi 
h×nh hép ®· tån t¹i tr­íc ®ã (Edit → Solidify ..). 
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 12.2 vÝ dô t¹o mÆt Boundary theo hai h­íng 

 Xo¸ mÆt Boundary võa t¹o trªn c©y th­ môc Tree model   
 B©y giê ta x©y dùng mÆt ®i qua c¶ 4 ®­êng c¬ 1,2,3,4  

 KÝch biÓu t­îng  trªn menu bar .NhÊn CTRL chän ®ång 
thêi hai ®­êng c¬1 vµ c¬3 nh­ h×nh minh ho¹ d­íi ®©y. 

 
 Sau ®ã kÝch chuét tr¸i sang d¹ng chän ®­êng c¬ thø hai nh­ 

h×nh minh ho¹ d­íi ®©y   sau ®ã l¹i 
nhÊn CTRL chän ®ång thêi ®­êng c¬ 2 vµ 4 ®­îc nh­ h×nh minh 
ho¹ 

 

t
µ

i 
li

Ö
u

 h
ä

c
 t

h
iÕ

t
 k

Õ
 v

µ
 t

h
ù

c
 h

µ
n

h
 t

r
o

n
g

 P
r

o
 e

n
g

in
e

e
r

 2
.0

 

mailto:Dangthanhhai1978@yahoo.com


Dangthanhhai1978@yahoo.com                           
 

Kü s­ CAD/CAM         Chuyªn thiÕt kÕ chÕ t¹o gia c«ng khu«n mÉu  

 C¸c b¹n cã thÓ dïng bÒ mÆt nµy ®Ó c¾t khèi h×nh Solid ®· 
vÏ tr­íc nã ®­îc nh­ h×nh minh ho¹ d­íi ®©y. 

 Ghi chó : ta cã thÓ t¹o mÆt Boundary theo mét hoÆc hai h­íng , 
trªn mçi h­íng nµy cã thÓ cã n ®­êng cong kh¸c nhau nÕu theo hai h­íng 
ta ph¶i ®Ó ý ®Õn vÊn ®Ò giao nhau cña c¸c ®­êng cong trong kh«ng gian 
kh«ng cã th× sÏ kh«ng thÓ tiÕn hµnh t¹o mÆt cong ®­îc c¸c b¹n cã thÓ lµm 
thªm vÝ dô 3 hay 4 ®­êng cong theo mét h­íng ®Ó hiÓu s©u thªm vÒ lÖnh 
nµy. 

 C¸c b¹n cã thÓ tiÕn hµnh vÏ chai nh­ minh ho¹ d­íi ®©y ®Ó 
cã nh÷ng hiÓu s©u thªm vÒ lÖnh vÏ Boundary blend , ta dùng bèn 
®­êng c¬ lµm ®­êng bao quanh , ®¸y chai lµ mét h×nh ch÷ nhËt 
52x70mm ®­îc bo trßn bèn gãc R=15mm , miÖng chai lµ ®­êng 
trßn ®­êng kÝnh 20mm . 
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 Chän c¸c ®­êng c¬ theo hai h­íng nh­ h×nh minh ho¹ d­íi 
®©y 
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 Sau khi ®­îc h×nh bao cña Chai , ta cã thÓ dïng lÖnh 
Extrude (d¹ng Surface) vÏ mÆt ®¸y vµ miÖng sau ®ã Merge víi 
mÆt Boundary th©n chai ®· vÏ ë trªn → chuyÓn sang d¹ng Solid 
→ T¹o rçng khèi h×nh chiÒu dÇy thµnh = 2mm ta ®­îc h×nh minh 
ho¹ d­íi ®©y. 

 

 
 
 

 Hµ Néi ngµy 30  th¸ng 05 n¨m 2007 
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